Home
Project Folders
Teacher Resources
Student Resources
How Do I?
Literacy
MWForum
Site Map
Search
Our Team

MWForum Message [Date Index] [Threads] [Authors] [Attachments] [Subscribe]

[Thread Prev] [Thread Next]

To: mwforum@xxxxxxxxxxxxxxxxxxxxxxxxxxxx
Subject: Re: problems with running random procedures in the same time
From: zehava wizman <zehavawi1@xxxxxxxxx>
Date: Sun, 25 Feb 2007 20:40:10 -0800 (PST)

Hi!
  thanks for your quick answer.
  I tried  to Invoke "target" only once in startup,and the problem still exist 
writting an error:
  "I can't start a new process" - I understand why its happened but I dont 
know how to overcome it.
  The problem with reaching the lowest limit of size, even I added condition 
(B1 proc marked with red) maybe it  also occured because of launching the 3 
procedures ,but what shall be done?
  I shorten the project to few  procedures with english names, so you can see 
the problems .
   What about my question what steps must be done to show the project to other 
children that have not Microworlds on their computer?
    Thanks , Zehava
  

Alain LCSI <alain@xxxxxxx> wrote:
  Hi,   

  Problem number 1
  You are right about using "launch" for running a few procedures run at the 
same time, such as launch [this] launch [that]. However, if these procedures 
take a long time to execute, doing a forever [launch [this] launch [that]] 
will start too many processes because you will launch a new set of this and 
that while you already have some this and that running.
  

  I cannot read your procedures because on my system, all procedure names 
consist of "invisible characters". Quite hard to track.
  

  Problem number 2 is a very common problem that requires "reading and 
tracing" your code line by line. I bet that you are issuing a forever [target] 
command somewhere, and the target procedure is itself doing a forever. Try to 
see that as "forever forever", in other words, "contnuously launch processes 
that launch processes". That's how you get the message "can't start a new 
process". MW can run a few tens processes (50 I believe) and after that, the 
next process is one too many.
  

  Solution: resolve the "forever forever" issue. Invoke "target" only once.
  

  
    Alain Tougas
  alain@xxxxxxx
  B: (514) 939-8700 poste 237
  




    Le 07-02-24 à 23:57, zehava wizman a écrit :

    Hello Forum!
  According to Alain advises there are 4 procedures that run randomally some 
sub-procedures (in the attaced project  random1 random2 random3 random4).
  How can I prepare a proc that will run the all procedures in the same time 
(the procedures are not belonged  to  turtles ,so  I can't use  everyone 
[clickon])
   I tried to do it with launch and forever,  but there are 2  problems:
  1. Within some procedure, there is setsize ? 1 instruction , that even I 
write condition to limit the size,  the launch and forever make inorder in it.
  2. There is a procedure that used  forever [setpos mousepos , called target, 
so there is an error "I can't start a new process in ask".
  How can I solve the problem?
   
  Other question:
  Where can I read about converting Microworlds project to html file, so 
children without Microworlds could use the project?
                               Thanks, Zehava Wizman
   
   
   
   
  

  
---------------------------------
  Bored stiff? Loosen up...
Download and play hundreds of games for free on Yahoo! Games.   
<launch-forever.zip>





 
---------------------------------
Be a PS3 game guru.
Get your game face on with the latest PS3 news and previews at Yahoo! Games.

Attachment: launch-forever1.zip
Description: 3959677046-launch-forever1.zip


  • Previous by thread: Re: problems with running random procedures in the same time
  • Next by thread: Re: problems with running random procedures in the same time

  • To save an attachment to your computer, PC users should right-click (Mac users, click and hold the mouse button) on the link and then choose 'save target as' from the pop-up menu. A window will then pop up in which you can choose a location for the file.


    © copyright 2001 - 2008